Tools

DWGCompare #

If you’ve made minor changes to your drawing and saved as different copies, few days later, you may have a hard time to recall what the changes you’ve made. AutoDWG compare helps you compare 2 revisions of your drawings and list every change clearly. Also you may use this feature for the collaboration and check out changes made by your team members.

Step1. Option1. Go to “Tools” > “DWG Compare…”


Option2. Press the “Find differences between versions” button on the tool bar.


If you are in the Browser mode, go to “File” > “DWG compare”.


Step 2. Click “…” buttons to add your 2 versions of drawing files. You may use the examples in the DWGSee installation folder (default location: C:\Program Files (x86)\AutoDWG\DWGSee Pro 2021).

Note: Click the “Setting” button to find more compare options.

Step 3. Click “OK” to compare and highlight differences in two drawings.

Find text #

Just like we need to search a word in any document, to search texts in a DWG, DXF or DWF drawing is much easier with DWGSee. No matter it is in text, text node, title block, vertical or angled texts with pointer, DWGSee will help you locate it and highlight it in the center of the screen, and all found texts will be listed in the right side pane, you may select “cases sensitive” “match whole word” to narrow finding results. Or search part of the word for wilder researches.

Step 1. Option1. Go to the “Find” button on the navigation bar.


Option2. Go to “Tools” > “Find”.


Option3.Option3. Hold “Ctrl” and press “F” on your keyboard.

Step 2. Type what text you want to find then click “OK”. The search results are limit to current space (model or layout). 

Example In this example, I would like to see where Jane’s desk is in our new working place, so I enter “A” in the textbox and finally located A.

Find drawings by keywords #

It is an advanced feature which is available in the “Browser mode” so that you can search texts in multiple drawings in one go. You may search in a folder, even within its subfolder. DWGSee will traverse all the drawing files for the occurrences of the matched texts.

Step 1. Hold “Ctrl” and press “B” to go to the Browser mode.

Step 2. Run the command Option1. Find the “Search text in drawings” button on the tool bar
Option2. Right click in the view, and find the “Search text in drawings” item
Option3. Right click on a drawing thumbnail and find the “Search text in drawings” item

Step 3. Type the test, choose a destination folder and click “OK”.

Step 4. Double click on a drawing thumbnail to view the drawing. Use arrow button on the toolbar to switch drawings.
Note: You may want to search again in the drawing to locate the specific text in a drawing, please see >> Search and find text in the drawing.
Example I searched a keyword and it gives me 2 results. Double clicked one file and open the drawing. Now use the arrow buttons “Next drawing” and “Previous drawings” to browse all the matched drawings for reviews. To precisely locate a keyword, hold “Ctrl” and press “F” to find the text location in the drawing.

Find by type #

Find the text by entity type, such as find by dimension.

Step 1. Click “Tools/Find by type”


Step 2, choose the entity type settings.


Step 3, click the data to find the entity in the drawing.

Count #

DWGSee “Counting Items” feature allows you to mark the entities or blocks by checks, and counting number of the checks you’ve made. When symbols or attributed blocks uses in your drawing, this program can automatically search and check every of them, just in one click. The blocks do not have to have attribute definitions. Nested blocks and xref’s blocks are all supported.

Step 1. Please Open the drawing and find the “Count Items” on the toolbar.


Step 2. Find the “New” button to define a new group of entities. Give the group a name and type it in the “Item Name” box, to count all the instances of a same block in the drawing, make sure check the “Search and check all similar items”, then click “OK”.


Step 3. Get back to the drawing and you will find that when the mouse hovers, the mouse arrow will turn into a square or a gray mark sign. When it sniffers a block entity, the mouse shape turns into a square, in this way, you may click the mouse key and DWGSee will count out how many times the selected block are instanced in the drawing. You may find the calculated quantity shown in the “Counter Manager”. A green mark sign will then be added to each counted block on the screen.

Note: To better help getting an accurate result, it is suggested to use your mouse wheel to zoom in before you tick on screen.

Step 4. A gray mark sign allows you to select a single entity. If you want to add more entities to a same group, just tick the blocks individually as you want and DWGSee will continue counting the number.

Mearure object #

Step 1, Menu: Tools/Measure
Step 2, Specify the two points to measure.
Measure result as following.

Measure Polyline #


• Menu tools/ measure polyline
• Specify the polyline to measure
• Right click the finish the measure.
• Check the result and then continue


Sum lines length #


• Click menu tools/ sum lines length
• Specify the lines to sum
• Right click then confirm.

Calculate Area #


• Click menu tools/Calculate Area, or click the button of area,
• Specify the area to calculate
• Check if you need markup the result in the drawing

Calculate selected entity area #

• Click menu Tools/Calculate selected entity area
• Specify the entity to calculate area
• Check if you need markup the result in the drawing

You can calculate the enclosed area and perimeter or circumference of circles, ellipses, polylines, polygons and regions. The information displayed depends on the type of object selected:
• Circles. Displays area and circumference information.
• Ellipses, closed polylines, polygons, planar closed spline curves, and regions. Displays area and perimeter information.
• Open objects such as open spline curves and open polylines. Displays the area and length; the area is calculated as though a straight segment connects the start and end.

Area summation #

• Use Calculate Area to mark several areas at first
• Click menu tools/area summation
• Check the result.
• Export the result or insert the result table to current drawing.

Insert table result

Copy objects #

Copy the vector drawing into a Word document
Raster images make for large file sizes or fuzzy printouts so that to inset a vector image into a word document is a good choice. DWGSee offers such sweet function for you. Creating WMF/EMF figures for Microsoft Office suites, you can just copy and paste any part of your DWG, DXF or DWF drawing to a Word document and make it scalable still.

Step 1. You have 3 options to call the copy function from DWGSee:
Option1. Go to “Tools” and find the copy options.
Option2. Right-click on the drawing and find the copy options.

Option3. Hold “Ctrl” and press “C” to copy the current view or hold “Ctrl” and press “R” to copy a certain part of the drawing in clipboard.


Step 2. Go to your MS document, and paste the vector image there.

Extract table #

For real table object, you can just double click the table to extract.
• Step1, Double click the table object in the drawing.
• Step2, Check and edit the value in the table.
• Step3, Save to csv file.


For regular line/text formatted table, you may choose “Tools/extract table/Select table to extract”, and then framed select the table area to extract.

For special formatted table, our advanced feature also can extract, any kind of table templates that is preliminary defined in your company can be customized and batch extracted in .xls files, import to database .etc.


Please note, this is the advanced feature, if you need that, please kindly contact us for more details: info@autodwg.com

Magnifier #

Hotkey: CTRL+M
Menu: Tools–Magnifier

Tips1, Change the magnification (Right click the windows)


2, Change the size of the magnifying glass.
3, You can also use Magnifier in the browser mode. (Right click the preview and then choose “show/hide Magnifier”)

Hawk-eye #

Menu: Tools-Hawk-eye

Purge #

Menu: Tools-purge
Remove unused items, such as block definitions and layers, from the drawing.
Unused named objects can be removed from the current drawing. These include block definitions, dimension styles, groups, layers, linetypes, and text styles. Zero-length geometry and empty text objects can also be removed.

• Click menu tools/Purge
• Check the objects to purge
• Check if you need verify each name to be purged, enter Y or N.
• Check the purge result as following.

Scroll to Top